ATI Linux Video Driver 9.8 Supports Ubuntu 9.04

ATI Catalyst 9.8 brings support for Linux kernel 2.6.29 and 2.6.30

  ATI Radeon logo
Advanced Micro Devices announced last night (August 17th) a new version of its versatile ATI Catalyst proprietary Linux display driver, for both x86 and x86_64 architectures. The ATI Catalyst 9.8 suite updates the software to version 8.64 and brings support for Red Hat Enterprise Linux 4.8 and Ubuntu 9.04 (Jaunty Jackalope).

Another new, interesting feature in this release is the support for RandR 1.2, in the ATI Catalyst Control Center. Display rotation, desktop sizing and multiple display arrangement are also available in the ATI Catalyst Control Center Linux Edition Display Manager.

Among the resolved issues in ATI Catalyst 9.8, we can mention:

· Ubuntu 9.04 users, with multi ASIC configurations, can now benefit from a normal mouse-cursor movement between displays (that means no more static cursors);
· HDTV PAL mode is now available in the Display Manager section of the Catalyst Control Center;
· Thanks to the RandR 1.2 extension API, monitor detection works instantly now;
· Repaired some CrossFire settings issues when pressing the cancel button, in Catalyst Control Center;
· If Rotate is specified in the xorg.conf file, the X server will no longer fail to start;
· No more error messages when aticonfig is executed on a new Ubuntu 9.04 installation;
· Users are now finally able to toggle between terminals (no more system freeze).

Once again, lots of known issues remain unresolved for this release of the ATI Catalyst suite!

Requirements:

· X.Org 6.8, 6.9, 7.0, 7.1, 7.2, 7.3 or 7.4;
· Linux kernel 2.6 or higher;
· glibc version 2.2 or 2.3;
· Support for POSIX Shared Memory (/dev/shm) is necessary for 3D programs;
· The following packages should be installed on your system: XFree86-Mesa-libGL, libstdc++, libgcc, XFree86-libs, fontconfig, freetype, zlib and gcc.

Also, please note that 64-bit users must have the 32-bit libraries installed before executing/updating the driver! Moreover, a GCC compiler, kernel-headers and kernel-source are required to build the modules and to enable 2D and 3D acceleration.

Supported operating systems:

· Red Hat Enterprise Linux;
· Novell SUSE Enterprise Linux;
· Ubuntu Linux.

Detailed installation instructions for the ATI Catalyst installer can be found in this PDF file.

Download the ATI/AMD Linux Display Driver 9.8 right now from Softpedia.

Comments

By    18 Aug 2009, 17:34 GMT